您现在的位置:首页 > >

实验二交换实验_VLAN及链路冗余实验报告

发布时间:

.
实验二 交换实验_VLAN 及链路冗余 一、 实验名称
本次实验的实验名称为:交换实验,主要分为以下几个小实验: (1)同一交换机 VLAN 的划分,也称为交换机端口的隔离; (2)不同交换机上 VLAN 的划分 (3)三层交换机使不同 VLAN 互通 (4)端口聚合提供冗余链路
二、 实验目的
1. 同一交换机 VLAN 的划分 在实现同一交换机 VLAN 的划分实验中,我们主要的目的是理解 Port Vlan
的配置,动手实现在同一个交换机上划分 VLAN。 2. 不同交换机上 VLAN 的划分
在实现不同交换机上 VLAN 的划分实验中,我们主要的目的是理解跨交换机 之间 VLAN 的特点,可以动手实现在不同的交换机上划分 VLAN。 3. 三层交换机使不同 VLAN 互通
在利用三层交换机实现不同 VLAN 互通的实验中,我们主要的目标是使用三 层交换机实现不同 VLAN 间互相通信。 4. 端口聚合提供冗余链路
在实现交换机的端口聚合以提供冗余链路的实验过程中,我们的主要目标是 理解链路聚合的配置及原理,动手实现交换机端口的聚合。
三、 实验设备
在本次实验的过程中,主要要求的实验设备有交换机 2 台:三层 S3550-1, 二层 S2126G-1;PC 机 4 台:PC1,PC2,PC5 和 PC6 以及若干条直连线和交叉线。
四、 实验拓扑图
1. 同一交换机 VLAN 的划分 该实验主要使用了二层交换机 S2126G-1 和两台 PC 机 PC5、PC6,IP 地址设
置、连接端口号的设置如下图(1)所示:
教育资料

.
图(1)
2. 不同交换机上 VLAN 的划分 该实验主要使用了二层交换机 S2126G-1、三层交换机 S3550-1 以及四台 PC
机 PC1、PC2、PC5、PC6,IP 地址设置、连接端口号的设置如下图(2)所示:
图(2)
3. 三层交换机使不同 VLAN 互通 该实验主要使用了二层交换机 S2126G-1、三层交换机 S3550-1 以及四台 PC
机 PC1、PC2、PC5、PC6,IP 地址设置、连接端口号的设置如下图(3)所示:
教育资料

.
图(3)
4. 端口聚合提供冗余链路 该实验主要使用了二层交换机 S2126G-1、三层交换机 S3550-1 以及四台 PC
机 PC1、PC2、PC5、PC6,IP 地址设置、连接端口号的设置如下图(4)所示:
图(4)
五、 实验内容(步骤)
1. 同一交换机 VLAN 的划分 (1)按照实验拓扑图进行网络的连接和配置。 (2)测试未划分 VLAN 时,PC5 和 PC6 两台 PC 机互相 ping 是否可以通。实
教育资料

.
验结果如下图(5)所示:

图(5)

由此可以看出,未划分 VLAN 时,连接在同一交换机上的 PC5 和 PC6 两台主

机是可以相互 ping 通的。

(3)创建 VLAN,配置二层交换机 S2126G-1,输入代码如下所示:

Switch>enable Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#name test10 Switch(config-vlan)#exit Switch(config)#vlan 20 Switch(config-vlan)#name test20 Switch#show vlan

!进入交换机全局配置模式 !创建 vlan 10 !vlan 10 命名为 test10
!创建 vlan 20 !vlan 20 命名为 test20 !查看已配置的 vlan 信息

实验代码和实验结果如下图(6)所示:

教育资料

.
图(6)
(4)将接口 F0/4 分配到 VLAN 10,接口 F0/5 分配到 VLAN 20,输入代码如 下所示:
Switch#configure terminal Switch(config)#interface fastethernet 0/4 Switch(config-if)#switchport access vlan 10 !将 F0/4 加入 VLAN 10 Switch(config-if)#interface fastethernet 0/5 Switch(config-if)#switchport access vlan 20 !将 F0/5 加入 VLAN 20 Switch(config-if)#end Switch#show vlan
实验代码和实验结果如下图(7)所示:
教育资料

.
图(7)
(5)测试划分 VLAN 之后,PC5 和 PC6 两台 PC 机互相 ping 是否可以通。实 验结果如下图(8)所示:
图(8)
由此可以看出,划分 VLAN 之后,连接在同一交换机上的 PC5 和 PC6 两台主 机之间不可以相互 ping 通。 2. 不同一交换机上 VLAN 的划分
(1)按照实验拓扑图进行网络的连接和配置。 (2)测试未划分 VLAN 时,PC1 和 PC5,PC2 和 PC5 PC 机之间互相 ping 是否
教育资料

.
可以通。实验结果如下图(9)所示:

PC1 ping PC5

PC2 ping PC5

图(9)

由此可以看出,未划分 VLAN 时,连接在不同交换机上的 PC1 和 PC5 两台主

机以及 PC2 和 PC5 两台主机是不可以相互 ping 通的。

(3)在三层交换机 S3550-1 上创建 VLAN 10,并将端口 F0/8 配置到 VLAN 10

中,输入代码如下所示:

Switch>enable Switch#configure terminal Enter configuration commands, one per line. Switch(config)#vlan 10 Switch(config-vlan)#name sales Switch(config-vlan)#exit Switch(config)#interface fastethernet 0/8 Switch(config-if)#switchport access vlan 10 Switch(config-if)#end Switch#show vlan id 10

End with CNTL/Z.

实验代码和实验结果如下图(10)所示:

教育资料

.
图(10)
(4)同理,在三层交换机 S3550-1 上创建 VLAN 20,并将端口 F0/9 配 置到 VLAN 20 中,实验代码和实验结果如下图(11)所示:
教育资料

.
图(11)
(5)把三层交换机 S3550-1 和二层交换机 S2612G-1 相连接的端口(F0/4) 定义为 tag Vlan。输入代码如下所示:
Switch#configure terminal Enter configuration commands, one per line. End with CNTL/Z. Switch(config)#interface fastethernet 0/4 Switch(config-if)#switchport mode trunk !在此处报错:Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode. 修改后的语句如下: Switch(config-if)#switchport trunk encapsulation dot1q Switch(config-if)#switchport mode trunk
实验代码和实验结果如下图(12)所示:
教育资料

.
图(12)
(6)在二层交换机 S2612G-1 上创建 VLAN 10,并将端口 F0/4 配置到 VLAN 10 中,输入代码如下所示:
Switch>enable Switch#configure terminal Switch(config)#vlan 10 Switch(config-vlan)#name sales Switch(config-vlan)#exit Switch(config)#interface fastethernet 0/4 Switch(config-if)#switchport access vlan 10 Switch(config-if)#end Switch#show vlan id 10
实验代码和实验结果如下图(13)所示:
教育资料

.

图(13)
(7)同理,在二层交换机 S2612G-1 上创建 VLAN 20,并将端口 F0/5 配 置到 VLAN 20 中,实验代码和实验结果如下图(14)所示:

教育资料

图(14)

.
(8)把二层交换机 S2612G-1 和三层交换机 S3550-1 相连接的端口(F0/1) 定义为 tag Vlan。输入代码如下所示:
Switch#configure terminal Switch(config)#interface fastethernet 0/1 Switch(config-if)#switchport mode trunk
实验代码和实验结果如下图(15)所示:

图(15)
(9)测试划分 VLAN 之后,PC1 和 PC5,PC2 和 PC5 之间是否可以互相 ping 通。实验结果如下图(16)所示:

教育资料

PC1 ping PC5

.

PC2 ping PC5

图(16)

由此可以看出,划分 VLAN 之后,连接在同一 VLAN 上但不连接在同一交换机

上的 PC1 和 PC5 两台主机之间可以相互 ping 通,而连接在不同 VLAN 上的 PC2

和 PC5 两台主机之间不可以互相 ping 通。

3. 三层交换机使不同 VLAN 互通

(1)本次实验依据“2. 不同交换机上 VLAN 的划分”实验的基础,进一步

进行配置,所以我直接利用上一次实验的配置结果。

(2)设置三层交换机 S3550-1 实现不同 VLAN 间的通信。实验所输入的代码

如下所示:

Switch>enable

Switch#configure terminal

Switch(config)#interface vlan 10

!创建虚拟接口 vlan 10

Switch(config-if)#ip address 192.168.1.254 255.255.255.0 !配置虚

拟接口 vlan 10 的地址为 192.168.1.254

Switch(config-if)#no shutdown

!开启端口

Switch(config-if)#exit

Switch(config)#interface vlan 20

!创建虚拟接口 vlan 20

Switch(config-if)#ip address 192.168.2.254 255.255.255.0 !配置虚

拟接口 vlan 20 的地址为 192.168.2.254

Switch(config-if)#no shutdown

!开启端口

Switch(config-if)#end

Switch#show ip interface

!查看 IP 接口的状态

实验代码和实验结果如下图(17)所示:

教育资料

.

图(17)

(3)将 PC1 和 PC5 的默认网关设置为 192.168.1.254,将 PC2 和 PC6 的默认

网关设置为 192.168.2.254。

(4)将三层交换机的路由功能开启。输入代码如下所示:

Switch>enable Switch#show ip route Switch#configure terminal Switch(config)#ip routing

! 查看路由表 ! 启用 IP 路由功能

实验代码结果如下图(18)所示:

教育资料

.
图(18)
(4)测试配置三层交换机之后,PC1 和 PC5,PC2 和 PC5 之间是否可以互相 ping 通。实验结果如下图(18)所示:

教育资料

PC1 ping PC5

.

PC2 ping PC5 图(18)
4. 端口聚合提供冗余链路 (1)按照实验拓扑图进行网络的连接和配置。 (2)观察可得,两个交换机之间的两条线不是全部都通的,其中一条是断
开的。实验结果如下图(19)所示:

教育资料

图(19)

.

(3)对三层交换机 S3550-1 进行配置,实验输入代码如下所示:

Switch>enable

Switch#configure terminal

Switch(config)#interface port-channel 1 !创建以太网通道 1

Switch(config-if)#interface range fastethernet 0/4-5 !进入端口

模式(端口 F0/4 和 F0/5)

Switch(config-if-range)#channel-group 1 mode on

!将以上端口指

定到已经创建的通道中

Switch(config-if-range)#switchport trunk encapsulation dot1q !

配置中继链路的封装类型

Switch(config-if-range)#switchport mode trunk ! 配 置 以 太 网 通 道

为中继模式(trunk)

实验代码如下图(20)所示:

图(20)

(4)同理,对二层交换机 S2612G-1 进行配置,实验输入代码如下所示:

Switch>enable

Switch#configure terminal

Switch(config)#interface port-channel 1

!创建以太网通道 1

Switch(config-if)#interface range fastethernet 0/1-2 !进入端口

模式(端口 F0/1 和 F0/2)

Switch(config-if-range)#channel-group 1 mode on

!将以上端口指

定到已经创建的通道中

Switch(config-if-range)#switchport mode trunk ! 配 置 以 太 网 通 道

为中继模式(trunk)

实验代码如下图(21)所示:

图(21)
(5)观察可得,两个交换机之间的两条线全部都通。实验结果如下图(22)所
教育资料

.
示:
图(22)
六、 实验结果(总结、分析)
1. 同一交换机 VLAN 的划分 根据以上实验结果,我发现未划分 VLAN 时,连接在同一台交换机上的两个
PC 机(IP 地址属于同一网段)之间是可以进行通信的,也就是可以 ping 通。但 是在将两台 PC 机划分到不同的 VLAN 中时,它们之间就不可以相互通信,即不同 VLAN 间的主机之间互相访问必须经由路由设备进行转发。Port Vlan 可以实现交 换端口的隔离,是实现 VLAN 的方式之一,它可以利用交换机的端口进行 VLAN 的划分,一个端口只能属于一个 VLAN。 2. 不同交换机上 VLAN 的划分
根据以上实验结果,我发现未划分 VLAN 时,连接在不同交换机上的两台 PC 机之间不可以 ping 通,即不能进行通信,但是对不同的交换机分别划分 VLAN 之后,连接在同一 VLAN 上但不在同一个交换机上的两个 PC 机之间也可以 ping 通,即进行通信。在本次实验,利用了 Tag Vlan 技术,它是基于交换机端口的 另外一种类型,它可以实现跨交换机的相同 VLAN 内主机之间的通信,同时对于 不同 VLAN 的主机进行隔离。Tag Vlan 遵循了 IEEE802.1q 协议的标准。 3. 三层交换机使不同 VLAN 互通
根据以上实验结果,我发现配置三层交换机之后,不同的 VLAN 之间的 PC 机 也可以实现 ping 通,即实现不同 VLAN 之间 PC 机的相互通信。在本次实验,利
教育资料

.
用了三层交换机来实现不同 VLAN 之间的互相访问,同样也可以利用路由器来实 现。之间的互相访问。三层交换机和路由器具备网络层的功能,能够根据数据的 IP 信息,进行选路和转发,从而实现不同网段之间的访问。
三层交换机实现不同 VLAN 之间互相访问的原理是:利用三层交换机的路由 功能,通过识别数据包的 IP 地址,查找路由表进行选路转发。三层交换机利用 直连路由可以实现不同 VLAN 之间的互相访问。三层交换机给接口配置 IP 地址, 采用 SVI(交换虚拟接口)的方式实现 VLAN 间互连。
交换虚拟接口,即 SVI,是指为交换机中的 VLAN 创建虚拟接口,并且配置 IP 地址。 4. 端口聚合提供冗余链路
根据以上实验结果,我发现实现端口聚合之后,可以实现链路的冗余备份, 而且这种方法还可以增加交换机之间的传输带宽。
经过本次实验,我了解到端口聚合(Aggregate-port)又称链路聚合,是指两 台交换机之间在物理上将多个端口连接起来,将多条链路聚合成一条逻辑链路, 从而增大链路带宽,解决交换网络中因带宽引起的网络瓶颈问题。多条物理链路 之间能够相互冗余备份,其中任意一条链路断开,不会影响其他链路的正常转发 数据。
教育资料



热文推荐
猜你喜欢
友情链接: 简历 面试求职范文 职业规划 自我管理 社交礼仪 76242百科